Abacus Updates

Security Vulnerability – Heartbleed

You may have heard of the Heartbleed bug — a security vulnerability that affects most of the known internet. On April 7, the OpenSSL project issued a security advisory that detailed this serious encryption software vulnerability.

As of 4/9/14 Abacus is no longer vulnerable.

While we have no reason to believe that this vulnerability has been used to attack us, we take security at Abacus very seriously. We encourage you to change your passwords not only on Abacus, but everywhere, as many other sites were affected.

More information can be found at heartbleed.com.

If you have any questions please email support@abacus.com.

– Josh

Related Posts